Вышел MIM hotfix rollup package (build 4.3.2266.0)

Майкрософт выпустила патч, исправляющий одну из наиболее раздражающих проблем, проявляющихся при использовании Sharepoint 2013 в качестве платформы для портала MIM/FIM.

Описание исправленной проблемы:

FIM Service

Issue 1
In SharePoint Server 2013 and later versions, if you edit a workflow or update an email template by using the FIM Portal, the version is automatically updated to 4.0.0.0. This causes a system error message during processing.

Вкратце: если вы изменяете или создаете новый workflow, в котором используется одна из стандартных активностей (например, Owner Approval Workflow, Password Reset Action Workflow и т.д.), документ XOML создается со ссылками на .Net version 4.0.0.0. Это приводит к полной неработоспособности workflow, т.к. требуемая версия .Net для данных активностей — 3.5.0.0. В журнале запросов MIM для запросов, завершенных с ошибкой, можно найти описание ошибки: «Unable To Create New WorkflowInstance For WorkflowDefinition».

Данная проблема ранее исправлялась ручным редактированием XOML-документа и исправлением версии .Net на 3.5.0.0.

Ссылка на статью KB, MIM 2016:
https://support.microsoft.com/en-us/kb/3171342
Ссылка на обновление, исправляющее ту же самую проблему в FIM:
https://support.microsoft.com/en-us/kb/3171318

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *